Unable to Load form Character Select


Dalayan Elder
Whenever I load to character select, my screen shows the character animations sped up (to the point where my character kinda looks like they are dancing and the attack animations are just weird twitches) and none of the buttons works on the screen using a mouse click. When I press enter It looks like it attempts to load into the game, but then always crashes to server select. I have tried to load from my usual steam install, a fresh steam install, an old titanium install, and repatching everything, nothing has produced a different result. I'm running windows 7. Does anyone have an idea on how to fix this? Thank you in advance.


Dalayan Beginner
It sounds like a processor multi-core issue on AMD processors, Everquest is designed to only use one core and it seems EQ is pretty good about assigning itself to only one core but in your case perhaps it's trying to use more then one, causing your game to run at ludicrous speed. I found some posts and articles where other folks have ran into the same issue. I haven't tested but give these solutions a go:



It looks like there's flags you can add to the game shortcut to force it to run on one core. Not sure how that'll work with the SoD patcher. Hopefully that helps!


Dalayan Elder
Thanks for the reply. I've tried playing with core assignments and so far no luck. I will keep trying though.
Top Bottom